Strecks

HomePage | RecentChanges | Preferences

Difference (from prior major revision) (no other diffs)

Added: 12a13,82

Maven 2 pom for Strecks:



<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>net.sourceforge.strecks</groupId>
<artifactId>strecks</artifactId>
<packaging>jar</packaging>
<version>1.0-alpha-1</version>
<name>Strecks</name>
<url>http://strecks.sourceforge.net</url>

<description>Strecks is a set of extensions to the Struts web development
framework aimed at Java 5 users. The aim of Strecks is to enhance the
capability of Struts in terms of productivity and maintainability. Strecks
makes use of Java 5 language features, in particular JSR-175 annotations, to
simplify the programming model for Struts applications.</description>

<scm>
<connection>scm:cvs:pserver:anonymous@cvs.sourceforge.net:/cvsroot/strecks:strecks</connection>
<url>http://cvs.sourceforge.net/viewcvs.py/strecks</url>
</scm>

<dependencies>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>servlet-api</artifactId>
<version>2.4</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>jsp-api</artifactId>
<version>2.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring</artifactId>
<version>1.2.7</version>
<optional>true</optional>
</dependency>
<dependency>
<groupId>struts</groupId>
<artifactId>struts</artifactId>
<version>1.2.9</version>
</dependency>
</dependencies>
<build>

<sourceDirectory>framework/src/java</sourceDirectory>

<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.5</source>
<target>1.5</target>
</configuration>
</plugin>
</plugins>

</build>

</project>


http://strecks.sourceforge.net/

Download: http://prdownloads.sourceforge.net/strecks/strecks-1.0-alpha-1.jar?download

Install for Maven 2:

$ mvn install:install-file -Dfile=strecks-1.0-alpha-1.jar -Dversion=1.0-alpha-1 
                           -Dpackaging=jar -DgroupId=org.strecks -DartifactId=strecks -DgeneratePom=true

(The code is in the org.strecks package.)

Maven 2 pom for Strecks:


<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
   <modelVersion>4.0.0</modelVersion>
   <groupId>net.sourceforge.strecks</groupId>
   <artifactId>strecks</artifactId>
   <packaging>jar</packaging>
   <version>1.0-alpha-1</version>
   <name>Strecks</name>
   <url>http://strecks.sourceforge.net</url>

   <description>Strecks is a set of extensions to the Struts web development
   framework aimed at Java 5 users. The aim of Strecks is to enhance the
   capability of Struts in terms of productivity and maintainability. Strecks
   makes use of Java 5 language features, in particular JSR-175 annotations, to
   simplify the programming model for Struts applications.</description>

   <scm>
      <connection>scm:cvs:pserver:anonymous@cvs.sourceforge.net:/cvsroot/strecks:strecks</connection>
      <url>http://cvs.sourceforge.net/viewcvs.py/strecks</url>
   </scm>

   <dependencies>
      <dependency>
         <groupId>javax.servlet</groupId>
         <artifactId>servlet-api</artifactId>
         <version>2.4</version>
         <scope>provided</scope>
      </dependency>
      <dependency>
         <groupId>javax.servlet</groupId>
         <artifactId>jsp-api</artifactId>
         <version>2.0</version>
         <scope>provided</scope>
      </dependency>
      <dependency>
         <groupId>org.springframework</groupId>
         <artifactId>spring</artifactId>
         <version>1.2.7</version>
         <optional>true</optional>
      </dependency>
      <dependency>
         <groupId>struts</groupId>
         <artifactId>struts</artifactId>
         <version>1.2.9</version>
      </dependency>
   </dependencies>
   <build>

      <sourceDirectory>framework/src/java</sourceDirectory>

      <plugins>
         <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
               <source>1.5</source>
               <target>1.5</target>
            </configuration>
         </plugin>
      </plugins>

   </build>

</project>

HomePage | RecentChanges | Preferences
This page is read-only | View other revisions
Last edited April 22, 2006 12:19 pm by WendySmoak (diff)
Search: